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Abstract 
 

  

These Application Notes describe the configuration steps required for QSC Q-Sys platform SIP 

Softphone to interoperate with Avaya Aura® Session Manager R8.1 and Avaya Aura® 

Communication Manager R8.1.  The QSC Q-Sys platform SIP Softphone is a conferencing 

phone that can use a SIP Trunk connection with Avaya Aura® Session Manager in support of 

voice communications and conferencing requirements. 

 

Readers should pay attention to Section 2, in particular the scope of testing as outlined in 

Section 2.1 as well as any observations noted in Section 2.2, to ensure that their own use cases 

are adequately covered by this scope and results. 

 

Information in these Application Notes has been obtained through DevConnect compliance 

testing and additional technical discussions.  Testing was conducted via the DevConnect 

Program at the Avaya Solution and Interoperability Test Lab. 
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1. Introduction 
These Application Notes describe the configuration steps required for QSC Q-Sys platform SIP 

Softphone to interoperate with Avaya Aura® Session Manager R8.1 and Avaya Aura® 

Communication Manager R8.1.  The QSC Q-Sys platform SIP Softphone is a conferencing 

phone that can use a SIP Trunk with Avaya Aura® Session Manager in support of voice 

communications and conferencing requirements.  

 

The Q-Sys Core is an Intel-based embedded Linux PC digital audio processor used for 

commercial installations. The Q-Sys Softphone feature of Q-Sys Core is completely virtual, 

requiring no additional hardware to function. The typical application of the Q-Sys Softphone is 

to provide a telephony endpoint to both conference rooms and wide-area paging. The Q-Sys 

Core product line runs on a Linux-based platform, which handle audio Digital Signal Processing 

tasks and support very scalable input/output channel counts from small to large, either locally or 

across a layer 3 infrastructure. The Q-Sys Softphone is a highly configurable SIP-based 

telephone endpoint which, because of its component nature within the Q-Sys environment, is 

accessible from any Windows-based desktop, iOS device or using the TCP-based External 

Control Protocol. 

2. General Test Approach and Test Results  
The general test approach was to place calls to and from the Q-Sys Softphone and exercise basic 

telephone operations. The main objectives were to verify the following:  

▪ Registration 

▪ Codecs (G.711, G.722, and G.729) 

▪ Inbound calls 

▪ Outbound calls 

▪ Hold/Resume 

▪ Serviceability 

 

DevConnect Compliance Testing is conducted jointly by Avaya and DevConnect members.  The 

jointly defined test plan focuses on exercising APIs and/or standards-based interfaces pertinent to 

the interoperability of the tested products and their functionalities.  DevConnect Compliance 

Testing is not intended to substitute full product performance or feature testing performed by 

DevConnect members, nor is it to be construed as an endorsement by Avaya of the suitability or 

completeness of a DevConnect member’s solution. 

 

Avaya recommends our customers implement Avaya solutions using appropriate security and 

encryption capabilities enabled by our products. The testing referenced in these DevConnect 

Application Notes included the enablement of supported encryption capabilities in the Avaya 

products.  Readers should consult the appropriate Avaya product documentation for further 

information regarding security and encryption capabilities supported by those Avaya products. 

                                                                                                     

Support for these security and encryption capabilities in any non-Avaya solution component is 

the responsibility of each individual vendor.  Readers should consult the appropriate vendor-

supplied product documentation for more information regarding those products.  
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For the testing associated with these Application Notes, the interface between Avaya systems 

and the QSC S-Sys Softphone utilized enabled capabilities of TLS and SRTP. 

 

2.1. Interoperability Compliance Testing 

The interoperability compliance test included features and serviceability. The focus of 

interoperability compliance testing was primarily on verifying call establishment on Q-Sys 

Softphone. The Q-Sys Softphone operations such as inbound calls, outbound calls, and its 

interactions with Session Manager, Communication Manager, and other Avaya SIP, and H.323 

phones were verified.  The serviceability testing introduced failure scenarios to see if Q-Sys 

Softphone can recover from failures. 

2.2. Test Results 

The test objectives were verified. For serviceability testing, Q-Sys Softphone operated properly 

after recovering from failures such as network disconnects, and resets of Q-Sys Softphone and 

Session Manager.  

 

The following features are not supported by Q-Sys at this time: 

▪ Call Hold/Resume  

▪ Call Transfer  

▪ Three party conference  

▪ Call Park/Unpark 

▪ MWI (Message Waiting Indicator) 

 

SRTP support for inbound calls to the softphone worked, but outbound calls using SRTP failed 

with an SDP Fault error on Communication Manager due to incompatible cyphers contained in 

the offer. QSC engineers provided a patch resolving this which is anticipated to be included in a 

future release of the product. 
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2.3. Support 

Technical support on QSC Q-Sys can be obtained through the following: 

 

Application Engineering and Technical Services 

Monday - Friday 7 AM to 5 PM PST (Excludes Holidays) 

Tel. 800-772-2834 (U.S. only) 

Tel. +1 (714) 754-6175 

 

Q-SYS 24/7 Emergency Support* 

Tel: +1-888-252-4836 (U.S./Canada) 

Tel: +1-949-791-7722 (non-U.S.) 

 

Q-SYS Support Email 

qsyssupport@qsc.com 

(Immediate email response times not guaranteed) 

 

  

mailto:qsyssupport@qsc.com
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3. Reference Configuration 
Once Q-Sys Softphone registers as a SIP endpoint with Session Manager, it can place and 

receive voice calls with various supported features as listed above in Section 2.1.  The reference 

configuration used for the compliance test is shown in Figure 1 below. 

 

 
 

Figure 1:  Q-Sys SIP Softphone with Avaya Aura® Session Manager and Avaya Aura® 

Communication Manager 
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4. Equipment and Software Validated 
The following equipment and software were used for the sample configuration provided: 
 

Equipment Software 

Avaya Aura® System Manager installed on VMWare R8.1 (8.1.0.0.079880) 

Avaya Aura® Session Manager installed on VMWare R8.1 (8.1.0.0.810007) 

Avaya Aura® Communication Manager installed on 

VMWare 
R8.1 (vcm-018-01.0.890.0) 

Avaya Aura® Media Server installed on VMWare R8.0 (v.8.0.0.169) 

Avaya Aura® Communication Manager Messaging 

installed on VMWare 
R7.0 (vcmm-07.00.0.441.0) 

Avaya 96x1 IP Deskphone (H323) R6.6506 

Avaya 96x0 IP Deskphone (H.323) R3.280 

Avaya JXX SIP Deskphone R3.0.0.0.16 

QSC Q-Sys Designer 8.1.1 

QSC Q-Sys Core 110f 8.1.1 

QSC Q-Sys Softphone  8.1.1 
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5. Configure Avaya Aura® Session Manager 
This section provides the procedures for configuring Session Manager.  The procedures include 

adding a SIP Trunk to the QSC Q-Sys Core server. 

 

Configuration is accomplished by accessing the browser-based GUI of System Manager using 

the URL “https://<ip-address>/SMGR”, where <ip-address> is the IP address of System 

Manager.  Log in with the appropriate credentials.  

 

A typical existing environment of Avaya Aura® components was used, this section covers only 

the modifications required for testing the QSC solution. 

 

Note that the fields modified in this section are for this reference configuration only; defaults are 

used for all other fields. 
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5.1. Add SIP Trunk 

The QSC Q-Sys Core server was entered as a SIP Entity on Session Manager using the following 

steps.  

5.1.1. Add SIP Entity 

Navigate to Home → Elements → Routing → SIP Entities and configure as follows. This 

configuration is automatically synchronized with Session Manager. 

 

Enter values for the following required attributes for SIP Entity:  

▪ Name:   Enter a name for the Entity 

▪ FQDN or IP Address: Enter the Address of the QSC Q-Sys Core server 

▪ Type:  Select SIP Trunk 

▪ Adaptation:  Select the QSC Adaptation (created below) 

▪ Location:   Select a valid location (optional) 

▪ SIP Link Monitoring: Select Link Monitoring Disabled 

 

Click Add to create an Entity Link to Session Manager. Note that this configuration was tested 

with both UDP and TLS and the corresponding ports. The UDP configuration is shown below. 
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5.1.2. Add Adaptation 

Navigate to Home → Elements → Routing → Adaptations and click New (not shown) to 

create a header manipulation rule for the SIP Trunk. The purpose is to set the destination domain 

to the IP Address of the Q-Sys Core server on messages sent to the server, and the lab 

environment domain for messages sent to Session Manager. Provide the following: 

• Adaptation Name: Enter a unique name 

• Module Name: Select DigitConversionAdapter 

• Module Parameter Type: Select Name-Value-Parameter 

• Click Add to specify the following parameters: 

o Name: fromto Value: true 

o Name: iodstd Value: sildenver.org 

o Name: iosrcd Value: sildenver.org 

o Name: odstd Value: 10.64.115.39 

• Click Add to create an Incoming Digit Conversion rule to remove the + on incoming 

messages from QSC 

• Click Add to create an Outgoing Digit Conversion rule to add the + on outgoing 

messages to QSC 
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5.1.3. Add Routing Policy 

Navigate to Home → Elements → Routing → Routing Policies and click New (not shown) to 

create a routing policy rule for the SIP Trunk. The purpose is to set the destination for calls to the 

softphone extensions to the QSC solution. Provide the following: 

• Name: A generally descriptive name for the Routing Policy. 

• SIP Entity as Destination: Click Select and choose the SIP Entity created in the 

previous step (not shown). 

• Dial Patterns: Click Add to display the Dial Pattern Details page, more details on this 

below. 
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On the Dial Pattern Details page, enter the digit pattern, min and max digits, and SIP Domain to 

be used for this rule.  

Click on Add to assign the Originating Location and Destination. 
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6. Configure QSC Q-Sys Core and Q-Sys Softphone 
Run the Q-Sys Designer software on a Windows desktop. Select Tools → Show Q-Sys 

Configurator. 

 
 

Select the Core model being configured for Softphone usage from the list of discovered Cores in 

the left column of the Q-Sys Configurator. Click on the link in the middle of the window that 

says Open Configuration Page. 
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Set the appropriate network settings on the network interface used to connect to Session 

Manager. LAN A is often used for connection to Q-Sys peripherals, and LAN B is often chosen 

to isolate VoIP traffic from other Q-Sys audio and control traffic. End user can configure any 

network interface for use with Communication Manager. For this testing, LAN A was chosen 

and configured as shown below. Click Edit to change the network settings and then Save. 
 

 
 

Copy the Core name from the Configurator to the Core Properties section on your design and 

choose the proper model.  
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In the far-left column of Q-Sys Designer, click on plus sign to add a Softphone instance to the 

current design file. 

 

 

 

The Add Inventory Item menu will appear to the right of the plus button showing all of the 

items available to add to the design. Navigate to and click Streaming I/O  Softphone to insert 

a Softphone instance to the Inventory list. The Add Inventory Menu disappears. Follow the 

same steps to add additional items to the design as needed. 
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This screenshot shows two softphones were added to the Inventory list of the design file. 
 

 
 

The name of each Softphone instance will be in the form Softphone-n, where n is an ascending 

integer value. The name may be changed to describe the room from which it will be used or the 

intended use of the instance. To change the name representing each Softphone instance, click on 

a Softphone instance in the Inventory Item list and edit the Name property field in the Properties 

section to the upper right side of the Q-Sys Designer user interface. The following screenshot 

shows that the Name property has been changed to describe the room where the Softphone 

instance will be used:  
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From the Inventory list, drag the individual components of the Softphone into the work area by 

clicking on the  icon. Alternately, click on the Softphone name and drag into the work area to 

place all three sub-components into the design at one time (as shown below). 
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The three sub-components each Softphone instance provides are the following: 

• Status/Control – this block contains the user interface for the dialpad, off/on hook, 

redial, auto-answer, local do-not-disturb (not the Communication Manager Do Not 

Disturb) and a Flash Hook button. Overall Status and call progress blocks, Off Hook and 

Ringing LEDs are provided for creating user interfaces for monitoring. There is also a 

call timer. 

• VoIP In – brings the incoming telephony audio into the Q-Sys design for routing as an 

audio source (Audio from Session Manager) 

• VoIP Out – receives the audio from the Q-Sys design which is intended to be sent as 

telephony audio (Audio to Session Manager). 
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Add components to the design by dragging, then “wire” them similarly to the softphone as 

shown below. To draw a wire between components, click within an audio pin circle and then 

drag the mouse and release the mouse button over another appropriate pin (outputs to inputs). 

 

An Acoustic Echo Canceller audio component should be included in the telephony signal path. 

This component is necessary in order to cancel any far-end audio which may be received by 

room microphones from being returned to the far end. The lower pin on the left side of the AEC 

component is the “Reference” pin. Any audio received on this pin will be automatically removed 

from the audio signal received from the room microphone(s) before being sent into the Q-Sys 

Softphone Out block for transmission. 
 

  
 

 

To “Deploy” the design to the Q-Sys Core press F5 or File → Save to Core & Run 
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Once the design is running and a green Core Status LED is visible in the upper left of the user 

interface, further configuration of the Softphone is required to allow registration to the Session 

Manager. Navigate to Tools → Show Q-Sys Core Manager or use the  button which 

appears in the upper right corner of the user interface. Once the Core Manager appears, select the 

Softphones tab.  

 

Select the codecs you wish to use with your configuration or click them all if you wish to have 

Session Manager control which codecs are used. Configure the port that matches your Session 

Manager configuration. For normal configurations this will usually be 5060. If encryption is 

being used it will normally be 5061. By default the Softphone uses RFC2833 and DTMF Type 

101. If needed change these values. The Softphone also supports the DTMF INFO method as 

well. When any changes are made within the Core Manager then you will need to click the Save 

button on the upper right. Changes are effective after the configuration is saved.  
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Click an entry in the Softphones list to be configured. A box in the lower right of the screen will 

show with the parameters for that softphone. Enter the softphone registration details similarly to 

those shown below.  

 

Register with proxy should be set to No when SIP Trunking is being used.  
 

  
 

Once the necessary changes have been made to the Softphone tab of the Administrator, click the 

Save button for the changes to take effect. 
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7. Verification Steps 
This section provides the tests that can be performed to verify proper configuration of Session 

Manager and Communication Manager with Q-Sys Softphone. 

• Verify codecs and encryption using status station (for calls connected to H.323 and DCP 

stations) or status trunk (for calls connected to SIP stations) commands in 

Communication Manager: 

 
status station 30002                                            Page   8 of   9  

                      SRC PORT TO DEST PORT TALKPATH 

src port: S000005      

S000005:TX:10.64.115.36:2062/g729a/20ms/1-srtp-aescm128-hmac80                   

001V011:RX:10.64.115.2:2056/g729/20ms/1-srtp-aescm128-hmac80:TX:ctxID:106        

001V012:RX:ctxID:106:TX:10.64.115.2:2052/g729/20ms/1-srtp-aescm128-hmac80        

T000001:RX:10.64.115.39:16486/g729/20ms/1-srtp-aescm128-hmac80     

 

status station 30002                                            Page   7 of   8  

                      SRC PORT TO DEST PORT TALKPATH 

src port: S000005      

S000005:TX:10.64.115.36:2062/g722-64/20ms/1-srtp-aescm128-hmac80                 

AMS1:RX:10.64.115.3:6008/g722-64/20ms/1-srtp-aescm128-hmac80:TX:cnfID:0          

AMS1:RX:cnfID:0:TX:10.64.115.3:6006/g722-64/20ms/1-srtp-aescm128-hmac80          

T000001:RX:10.64.115.39:16404/g722-64/20ms/1-srtp-aescm128-hmac80   

 

 
status trunk 10                                                                  

 

                             TRUNK GROUP STATUS 

 

Member    Port    Service State      Mtce Connected Ports 

                                     Busy 

 

0010/0001 T000001 in-service/active  no   T000005                             

0010/0002 T000002 in-service/idle    no                                       

0010/0003 T000003 in-service/idle    no                                       

0010/0004 T000004 in-service/idle    no                                       

0010/0005 T000005 in-service/active  no   T000001                             

0010/0006 T000006 in-service/idle    no                                       

0010/0007 T000007 in-service/idle    no                                       

0010/0008 T000008 in-service/idle    no                                       

0010/0009 T000009 in-service/idle    no                                       

0010/0010 T000010 in-service/idle    no                                       

 

status trunk 10/0001                                            Page   3 of   3  

                      SRC PORT TO DEST PORT TALKPATH 

src port: T000001      

T000001:TX:10.64.115.39:16446/g729/20ms  

AMS1:RX:10.64.115.3:6174/g729/20ms:TX:cnfID:0                                    

AMS1:RX:cnfID:0:TX:10.64.115.3:6176/g729/20ms/1-srtp-aescm128-hmac80             

T000005:RX:10.64.115.40:5004/g729/20ms/1-srtp-aescm128-hmac80                    

 

dst port: T000005      

 

status trunk 10/0005                                            Page   3 of   3  

                      SRC PORT TO DEST PORT TALKPATH 

src port: T000005      

T000005:TX:10.64.115.40:5004/g729/20ms/1-srtp-aescm128-hmac80                 

AMS1:RX:10.64.115.3:6176/g729/20ms/1-srtp-aescm128-hmac80:TX:cnfID:0             

AMS1:RX:cnfID:0:TX:10.64.115.3:6174/g729/20ms                                    

T000001:RX:10.64.115.39:16446/g729/20ms 

 

dst port: T000001 
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8. Conclusion 
These Application Notes describe the configuration steps required for QSC Q-Sys Softphone to 

successfully interoperate with Avaya Aura® Session Manager and Avaya Aura® Communication 

Manager. All feature and serviceability test cases were completed with the exceptions noted in 

Section 2.2. 

9. Additional References  
This section references the product documentation available at support.avaya.com relevant to 

these Application Notes.   

[1] Administering Avaya Aura® Communication Manager, Release 8.1.x, November 2019 

[2] Administering Avaya Aura® Session Manager, Release 8.1.1, October 2019 

[3] Implementing and Administering Avaya Aura® Media Server, Release 8.0.x, December 2019  
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